Andy Moore Mobile Plugin Patch

After I installed Andys great mobile plugin I found out that when you go into the option for the plugin there is no default category for mobile posting if your site is running WordPress 2.3.1 as they appear to have changed some of the mysql tables.

I changed his code to make it work.

You need to change the global $wpdb; portion of the code.

Here is the file detailing the patch: mobile-plugin-patch

I’m sure it possible to detect which version of wordpress you are using and alter this accordingly but I’ve just done this quick and dirty hack for me.